
 

                                                      
 

Managing Report Cards in SchoolInsight 
 
Report cards in SchoolInsight are comprised of two parts: 

1. The Report Card 
a. The bucket into which the data is entered 

2. The Assessment List 
a. Determines what data needs to be pulled from a course/class and put in the 

bucket 
 

Creating Report Cards 
Report cards can be managed at the school or school district level 
 
Admin Main > Grade Reporting > Define Report Cards 
*or SD Admin > Grade Reporting > Report Cards 
 

 
 
Grading periods and grade levels can be set for each report card.  
 
*Most schools have one report card per year. It is possible to have multiple report cards, though 
this is not necessary if the only difference is how the grades show. (i.e. if some students use 
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standards and others are traditional, you would not need a separate report card. If you would 
like different layouts or headers for your report cards, such as one for grade school and one for 
middle school, then you would create two report cards, each filtered to the appropriate grade 
levels) 
 
Creating Assessment Lists 
Admin Main > Grade Reporting > Assessment Lists 

 
 
Once an assessment list is created assessments can be added to it.  
Admin Main > Grade Reporting > Assessment Lists > Assessments 
 
There are three types of assessments in course-based mode: 

1. Give Letter Grade, Score, and/or Comments 
2. Standards-based Grades 
3. Circle Items in a list 

 
By default, assessments use the grading scale assigned to the course. If you would like to use a 
different report card for an assessment (i.e. a work habits line on the report card) that can be set 
as the grading scale for the assessment.  
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Give Letter Grade, Score, and/or Comments assessment setup 

 
 
Give Letter Grade, Score, and/or Comments on report card 
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Standards-based Grades assessment setup 

 
 

Standards-based Grades on report card 
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Circle Items in a list assessment setup 

 
 

Circle Items in a list assessment on report card 

 
 
Each assessment type can be included on a single assessment list with other assessments of a 
different type.  
 
The assessments will appear on the report card in the same order they are listed in the 
assessment list.  
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Attaching Assessment Lists to Courses 
Admin Main > Grade Reporting > Assessment Lists > Assign to Courses 
 
All courses using the same assessment list can be added at the same time by selecting the 
assessment list from the top and then selecting the courses. 
 

 
 

Each course can only have one assessment list for report cards, and one assessment list for 
progress reports. Courses intended to be on the report card should also be marked to “Show on 
Report Card.”  
 
*Classes will only show on the report card for a student if the student is on the roster for that 
class. 
 
In classic report cards, assessment lists are applied to classes from Admin Main > Grade 
Reporting > Define Report Cards > Classes 
 
In classic mode, each class needs to be added individually.  
 
 
Report Card Layout 
Admin Main > Grade Reporting > Define Report Cards > Visual Layout 
 
The visual layout requires a student to be entered in order to generate a preview. 
*The visual layout should be used as a preview only, not to pull report card data for a student 
 
The “Header & Message” tab can be used to edit the header, add a logo, or display a custom 
message at the top of the report card.  
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The “Visual Layout” tab can be used to preview the report card and make changes to the layout. 
The preview will update as changes are made. Once the design is correct, click “save.”  

 
Grading scales displaying on a student’s report card are pulled from classes and assessments 
used by classes in which the student is enrolled. If the incorrect grading scale is showing on a 
student’s report card, verify that that grading scale is not used in a class the student is on the 
roster for, and that the grading scale is not used on an assessment used by a course in which 
the student is enrolled.  
 
Traditional grading scales can be hidden from the report card from Admin Main > Grading 
Scales > Edit > uncheck “Print Scale on Report Cards/Transcripts” 
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The order in which classes appear on the report card can be defined in the sort order. 
Admin Main > Grade Reporting > Define Report Cards > Sort Order 
 
Classes can be sorted by course or subject area. Once they are added to the order, they can be 
dragged and dropped into the desired order. 
 

 
 

 
 

Report Card Grading Periods 
Admin Main > Grade Reporting > Define Report Cards > Grading Period Status 
 
Report card grading periods work independently from the grading periods used for classes and 
attendance and need to be adjusted separately. There are three statuses for report card grading 
periods: 

1. Closed - Can’t see or edit grades for this grading period 
2. Active - Can see and edit grades for this grading period 
3. Complete - Can view by not edit grades for this grading period 

 
Grading period modes can be changed at any time.  
 
It is considered best practice to keep future grading periods closed and mark previous grading 
periods as complete. It is not advised to have multiple grading periods open at a time as this 
increases the chance of grades being entered into the incorrect grading period.  
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Complete grading periods can be published to the parent portal by checking “Allow parents to 
generate report cards for “Complete” grading periods.” 
 

 
 
Importing Grades to Report Cards as an Instructor 
Instructor Main > Tools > Report Cards 
 
Click “Classes” next to the grading period and report card for which you would like to 
submit grades. 
 
*“Classes” will appear as “Subjects” if the instructor is set to Self Contained = Yes. 
There is no functional difference between the two. 
  
Click “Enter Grades” next to the class for which you would like to enter grades. 
 
**If the enter grades link is missing, the grading period is not marked as “Active.” 

Managing Report Cards in SchoolInsight 
© Common Goal Systems, INC. 2017 



 

                                                      
 

 
 
If grades have been entered in the gradebook, the instructor may be prompted to import 
those grades. 

1. If instructors are not prompted and would like to import grades, they can click the 
“Import Grades from Gradebook” button. 

 
Instructors can then enter/adjust grades and add comments or special grade codes.  
 
Once the report card is complete, instructors should check the “These report card 
grades are ready to be printed” box. 
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Finding Classes Missing Report Card Grades 
Admin Main > Grade Reporting > Classes with Un-entered Grades 
 
This report will display any classes missing report card grades and the instructor listed 
on the course. This report looks to see if the “These report card grades are ready to be 
printed” box is checked for courses. The “view” button can be used to verify if report 
card grades have been entered. 
 
Report Card Attendance 
Admin Main > Grade Reporting > Attendance 
 
Daily attendance can be imported onto the report card for each grading period using 
“Import Daily Attendance.”  
 
“Enter Attendance” can be used to edit the imported values, or to add attendance 
manually.  
 
*The report card grading period must be set to “Active” in order to import or enter 
attendance onto the report card. 
 
GPA 
Admin Main > Grade Reporting > Options 
 
GPA can be calculated as a single value, or as weighted and unweighted.  
 
Each GPA set needs to have a grade range. Multiple grade ranges can be used.  
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GPA values need to be added to the grading scales in order for proper calculation.  
Admin Main > Grading Scales > Edit 
 

 
 
In order to be used for GPA, the grading scale must be set to “Calculate Average” and “Used for 
Calculating GPA and Credits Earned: (Classes Will Show on Transcript)” must be checked.  
 

 
 
When using weighted and unweighted GPA, there are two options for calculating weighted 
GPA: 
 

1. Letter Grades for weighted classes have higher point values, as defined on the grading 
scale. For instance if A=4.0 for unweighted classes, in weighted classes A=5.0 

 
2. Calculate the unweighted GPA, and add an adjustment for the number of weighted 

credits taken. For example if unweighted GPA=4.0 and the student took 16 out of 32 
possible weighted credits, their weighted GPA would be 4.0 + 16/32 = 4.5 

Managing Report Cards in SchoolInsight 
© Common Goal Systems, INC. 2017 



 

                                                      
 

 
If using the second weighted GPA calculation, the possible weighted credits per semester must 
be set.  
 

 
 
If using weighted and unweighted GPAs, each course needs to be set as weighted or 
unweighted. Admin Main > Course Catalog > Edit > Report Cards tab 
 

 
 
This can be edited using the “Mass Edit” feature in the course catalog.  
 
When using GPA, before report cards can be generated, GPA must be calculated. GPA must be 
recalculated each time and instructor updates their report card. Students needing their GPA 
recalculated will display a red *NR on the Admin Main > Grade Reporting > GPAs page.  
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GPA can be calculated from Admin Main > Grade Reporting > GPAs > Calculate GPA. 
 

 
 
Once GPAs have been calculated, clicking them will display how the GPA was calculated.  
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Honor Roll 
Admin Main > Grade Reporting Honor Roll Scale 
 
The honor roll scale can be set by GPA and grade. Each level of the honor roll can be set to 
either show or not show on the report card.  
 

 
 
Multilingual Report Cards 
Admin Main > Grade Reporting > Define Report Cards > Use Multilingual Report Cards 
 

 
 
The languages used can be set from SD Admin > Options > Languages 
 

 
 
SchoolInsight currently supports Spanish and Polish in addition to English.  
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Use “Edit Report Card Translations” to edit the report card fields.  
 

 
 
Custom entries such as the report card header, assessment list titles, and course need to be 
entered manually using the language tabs.  
 

 

 
 
Language preference can be set for each student on Admin Main > Students - Single View > 
Search for a student > Edit  
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This can be set using the “Mass Edit” feature on Admin Main > Students - Multi View. 
 
When generating report cards, there is the option to generate in the student’s preferred 
language, or in a set language.  
 

 
 

Generating Report Cards 
Admin Main > Grade Reporting > Generate Report Cards 
 
Report cards can be generated for all students or groups of students. It is important to ensure 
the proper report card is selected from the top when multiple are used, and that the correct 
grading period is selected.  
 

 
 
Report card generation can take several minutes. This is especially true when generating for 
large groups of students, or instances where the report cards are several pages in length.  
(i.e. standards-based report cards) 
 
Copy Report Cards 
Admin Main > Grade Reporting > Define Report Cards > Copy Report Cards 
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Admin Main > Grade Reporting > Assessment Lists > Copy Assessment Lists 
 
Report cards and assessment lists can be copied from year to year. It is import to ensure the 
grading reporting mode is the same in both academic years before copying.  
 

 
 

 
 
Notes on Summary Grading Periods 
Admin Main > Grade Reporting > Options 
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*Reminder, there are two kinds of grading period in SchoolInsight:  

1. Regular 
a. Attendance is taken 
b. Grades are entered in gradebooks 
c. Do not show on transcripts 
d. Example: Q1, Q2, T1, T2 

2. Summary 
a. Grades are calculated 
b. Show on transcripts 
c. Example: Sem 1, Final 

 
This section is specifically about summary grading periods.  
 
There are three modes for calculating grades for summary grading periods in SchoolInsight: 

1. Grades are calculated from previous report card grades (recommended) 
2. Grades are calculated in gradebook 
3. Grades are calculated as a running total across grading periods 

 
Depending on the mode you select, the experience instructors have adding grades to these 
grading periods will be different. Please see the appropriate section below for the mode used at 
your school.  
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Calculating Averages - Summary GP - Previous Report Cards 
*This guide is for use with the Traditional Grades in Summary Grading Periods: Grades are 
calculated from previous report card grades (recommended). (Admin Main > Grade Reporting > 
Options) 
 

1. Log into the system and navigate from the Instructor Main to Tools > Report Cards 
2. Locate the report card and summary grading period for which you would like to calculate 

grades and select “Classes” 

 
*”Classes” may appear as “Subjects” depending on district settings. There is no change in 
functionality between the two.  
 

3. Locate the class and click “enter grades” 
 

**If “enter grades” is missing, please contact the TeacherEase Admin at your school to have 
them open the grading period. 
 

4. Click “Calculate Average” at the bottom of the page 

 
5. Adjust the weight for each grading period as necessary 

a. System defaults to current school or district settings 

 
6. Click “Calculate” 
7. Review the grades and click “Save” 
8. Check the box at the bottom for “These report card grades are ready to be printed” 
9. Click “Save” 
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Calculating Averages - Summary GP - Grades Calculated in Gradebook 
*This guide is for use with the Traditional Grades in Summary Grading Periods: Grades are 
calculated in gradebook. (Admin Main > Grade Reporting > Options) 
 

1. Log into the system and navigate to your gradebook 
2. Select the class and summary grading period from the dropdown 

 
3. Click the “Calculate/Enter Overall Scores” button at the bottom 

 

 
 

4. Adjust the weight for each grading period as necessary 
a. System defaults to current school or district settings 

 
5. Click “Preview” 
6. Review the grades and click “Save” 
7. Navigate to Tools > Report Cards 
8. Locate the report card and summary grading period for which you would like to import 

grades and select “Classes” 

 
*”Classes” may appear as “Subjects” depending on district settings. There is no change in 
functionality between the two.  
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9. Locate the class and click “enter grades” 

 
**If “enter grades” is missing, please contact the TeacherEase Admin at your school to have 
them open the grading period. 
 

10. Click “Import Grades from Gradebook” at the bottom of the page 
11. Click “Save” 
12. Review the grades and check the box at the bottom for “These report card grades are 

ready to be printed” 
13. Click “Save” 
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Calculating Averages - Summary GP - Running Total 
*This guide is for use with the Traditional Grades in Summary Grading Periods: Grades are 
calculated as a running total across grading periods. (Admin Main > Grade Reporting > Options) 
 

1. Log into the system and navigate from the Instructor Main to Tools > Report Cards 
2. Locate the report card and summary grading period for which you would like to import 

grades and select “Classes” 

 
*”Classes” may appear as “Subjects” depending on district settings. There is no change in 
functionality between the two.  
 

3. Locate the class and click “enter grades” 
 

**If “enter grades” is missing, please contact the TeacherEase Admin at your school to have 
them open the grading period. 
 

4. Click “Import Grades from Gradebook” at the bottom of the page 
5. Click “Save” 
6. Review the grades and check the box at the bottom for “These report card grades are 

ready to be printed” 
7. Click “Save” 
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